BMW X5 and X6 Forum 2014-Current
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Post Reply
 
Thread Tools Search this Thread
      09-22-2014, 11:31 PM   #89
opasha
Brigadier General
opasha's Avatar
833
Rep
3,991
Posts

Drives: 2014 BMW X5 50i
Join Date: Apr 2014
Location: Maryland

iTrader: (0)

Updated OP with the coding for having your cell ringtone play from the car's speakers through bluetooth upon receiving a call.
__________________
2014 X5 50i X-Line // Mineral White
Appreciate 0
      09-23-2014, 01:28 AM   #90
Snow-Kidney
Banned
43
Rep
421
Posts

Drives: F15
Join Date: Aug 2014
Location: SoCal

iTrader: (0)

great thread, O! thanks for maintaining.
Appreciate 0
      09-23-2014, 02:00 AM   #91
opasha
Brigadier General
opasha's Avatar
833
Rep
3,991
Posts

Drives: 2014 BMW X5 50i
Join Date: Apr 2014
Location: Maryland

iTrader: (0)

Quote:
Originally Posted by Snow-Kidney View Post
great thread, O! thanks for maintaining.
For sure .
__________________
2014 X5 50i X-Line // Mineral White
Appreciate 0
      09-24-2014, 09:43 PM   #92
opasha
Brigadier General
opasha's Avatar
833
Rep
3,991
Posts

Drives: 2014 BMW X5 50i
Join Date: Apr 2014
Location: Maryland

iTrader: (0)

Just an update regarding @r33's cheat sheet - LEGAL_DISCLAIMER_TIME (first module) is located in HU_NBT...not "hig." I fixed this in the cheat sheet and typed a little reminder in the OP regarding it. Thanks .
__________________
2014 X5 50i X-Line // Mineral White
Appreciate 0
      09-25-2014, 10:50 AM   #93
Hang0ver
Second Lieutenant
Hang0ver's Avatar
12
Rep
208
Posts

Drives: 2015 X5 35i
Join Date: Aug 2014
Location: Maryland

iTrader: (0)

@opasha thanks for your help in coding yesterday. It was really helpful. I have some questions on that.

I still don't see the disclaimer disappear and startup emblem working. I tested this morning and it still didn't work. Even though we did FDL after VO coding, I suspect if it didn't write the HU_NBT. But the HUD Turn signal signal is working fine which is in HU_NBT. Do I need to reset anything?

@skalberti : adding 6ns got the Office menu but its not pulling my iPhone 5s messages. I suspect it might be because its not compatible, but if anyone has info, can you please help me with that?

Last edited by Hang0ver; 09-25-2014 at 10:57 AM.
Appreciate 0
      09-25-2014, 12:32 PM   #94
r33_RGSport
Major General
r33_RGSport's Avatar
United_States
1047
Rep
7,067
Posts

Drives: G30 540i / 997.1 C4S / i3 REx
Join Date: Oct 2009
Location: So. Cal

iTrader: (2)

Quote:
Originally Posted by opasha View Post
Just an update regarding @r33's cheat sheet - LEGAL_DISCLAIMER_TIME (first module) is located in HU_NBT...not "hig." I fixed this in the cheat sheet and typed a little reminder in the OP regarding it. Thanks .
@opasha, yea, I noticed that yesterday. I guess someone was key happy and accidentally changed the variable.
Maybe I should just give you and @skalberti access to it, so it won't get messed up again. Let me know what do you think.
__________________
Appreciate 0
      09-25-2014, 12:34 PM   #95
r33_RGSport
Major General
r33_RGSport's Avatar
United_States
1047
Rep
7,067
Posts

Drives: G30 540i / 997.1 C4S / i3 REx
Join Date: Oct 2009
Location: So. Cal

iTrader: (2)

Quote:
Originally Posted by Hang0ver View Post
@skalberti : adding 6ns got the Office menu but its not pulling my iPhone 5s messages. I suspect it might be because its not compatible, but if anyone has info, can you please help me with that?
BMW still haven't crack the iPhone encryption yet, so we the iPhone users, can't use much of the Office features on the car. No text, no messages.
__________________
Appreciate 0
      09-25-2014, 01:54 PM   #96
opasha
Brigadier General
opasha's Avatar
833
Rep
3,991
Posts

Drives: 2014 BMW X5 50i
Join Date: Apr 2014
Location: Maryland

iTrader: (0)

Quote:
Originally Posted by Hang0ver View Post
@opasha thanks for your help in coding yesterday. It was really helpful. I have some questions on that.

I still don't see the disclaimer disappear and startup emblem working. I tested this morning and it still didn't work. Even though we did FDL after VO coding, I suspect if it didn't write the HU_NBT. But the HUD Turn signal signal is working fine which is in HU_NBT. Do I need to reset anything?

@skalberti : adding 6ns got the Office menu but its not pulling my iPhone 5s messages. I suspect it might be because its not compatible, but if anyone has info, can you please help me with that?
The splash screen can be funny at times from what I've noticed. There is another option you can try to edit in there. It deals with Animation, Splash, etc...I think it is under that same menu or STARTUP_TYPE aside from STARTUP_EMBLEM. Mess with that between splash and animation and see if it changes anything. Maybe someone else can comment regarding this. Mine works fine, and I did exactly what I did on mine to yours.
Quote:
Originally Posted by r33 View Post
@opasha, yea, I noticed that yesterday. I guess someone was key happy and accidentally changed the variable.
Maybe I should just give you and @skalberti access to it, so it won't get messed up again. Let me know what do you think.
Sure, you can add me to it .
Quote:
Originally Posted by r33 View Post
BMW still haven't crack the iPhone encryption yet, so we the iPhone users, can't use much of the Office features on the car. No text, no messages.
Thanks for answering this. I have no clue regarding what iPhones can/can't do with the car since I own an Android device.
__________________
2014 X5 50i X-Line // Mineral White
Appreciate 0
      09-25-2014, 02:00 PM   #97
skalberti
Captain
skalberti's Avatar
United_States
108
Rep
707
Posts

Drives: 2017 Mineral White M3
Join Date: Dec 2009
Location: Texas

iTrader: (0)

Quote:
Originally Posted by Hang0ver
@opasha thanks for your help in coding yesterday. It was really helpful. I have some questions on that.

I still don't see the disclaimer disappear and startup emblem working. I tested this morning and it still didn't work. Even though we did FDL after VO coding, I suspect if it didn't write the HU_NBT. But the HUD Turn signal signal is working fine which is in HU_NBT. Do I need to reset anything?

@skalberti : adding 6ns got the Office menu but its not pulling my iPhone 5s messages. I suspect it might be because its not compatible, but if anyone has info, can you please help me with that?
Go into your Bluetooth settings on your iPhone. Click on the I on the right side of the screen next to your bmw's VIN. That'll pull up another screen. Make sure "show notifications" is turned on. After turning it on, disconnect the phone from the car and then reconnect. Have someone send you a text while your connected to the car and the car is running. You'll will only get text notifications on your Idrive while you're connected to the car. Any unanswered texts you get before you connect to your car will not show up. Hope this helps!
__________________
It's good to be bad
Appreciate 1
      09-25-2014, 02:33 PM   #98
Hang0ver
Second Lieutenant
Hang0ver's Avatar
12
Rep
208
Posts

Drives: 2015 X5 35i
Join Date: Aug 2014
Location: Maryland

iTrader: (0)

Quote:
Originally Posted by r33 View Post
BMW still haven't crack the iPhone encryption yet, so we the iPhone users, can't use much of the Office features on the car. No text, no messages.
AAPL
Appreciate 0
      09-25-2014, 02:34 PM   #99
Hang0ver
Second Lieutenant
Hang0ver's Avatar
12
Rep
208
Posts

Drives: 2015 X5 35i
Join Date: Aug 2014
Location: Maryland

iTrader: (0)

Quote:
Originally Posted by opasha View Post
The splash screen can be funny at times from what I've noticed. There is another option you can try to edit in there. It deals with Animation, Splash, etc...I think it is under that same menu or STARTUP_TYPE aside from STARTUP_EMBLEM. Mess with that between splash and animation and see if it changes anything. Maybe someone else can comment regarding this. Mine works fine, and I did exactly what I did on mine to yours.
Will try that...About to order the cable to get prepared for my own coding era
Appreciate 1
      09-25-2014, 02:36 PM   #100
Hang0ver
Second Lieutenant
Hang0ver's Avatar
12
Rep
208
Posts

Drives: 2015 X5 35i
Join Date: Aug 2014
Location: Maryland

iTrader: (0)

Quote:
Originally Posted by skalberti View Post
Go into your Bluetooth settings on your iPhone. Click on the I on the right side of the screen next to your bmw's VIN. That'll pull up another screen. Make sure "show notifications" is turned on. After turning it on, disconnect the phone from the car and then reconnect. Have someone send you a text while your connected to the car and the car is running. You'll will only get text notifications on your Idrive while you're connected to the car. Any unanswered texts you get before you connect to your car will not show up. Hope this helps!
Yes. I already have notifications enabled. I did unpair them and paired again to make sure they are synced up.

I will try again today to see what happens.
Appreciate 0
      09-25-2014, 02:39 PM   #101
opasha
Brigadier General
opasha's Avatar
833
Rep
3,991
Posts

Drives: 2014 BMW X5 50i
Join Date: Apr 2014
Location: Maryland

iTrader: (0)

Quote:
Originally Posted by Hang0ver View Post
Will try that...About to order the cable to get prepared for my own coding era
Sounds good, let me know if you need any further help. Good luck!
__________________
2014 X5 50i X-Line // Mineral White
Appreciate 0
      09-28-2014, 10:52 AM   #102
Hang0ver
Second Lieutenant
Hang0ver's Avatar
12
Rep
208
Posts

Drives: 2015 X5 35i
Join Date: Aug 2014
Location: Maryland

iTrader: (0)

@opasha & @r33 :

can you check where you have the auto start stop OFF by default in comfort mode. in the cheat sheet its noted that it can be found in 3000. But I think I saw it in 3026. Atleast for me.
Appreciate 0
      09-28-2014, 10:55 AM   #103
Hang0ver
Second Lieutenant
Hang0ver's Avatar
12
Rep
208
Posts

Drives: 2015 X5 35i
Join Date: Aug 2014
Location: Maryland

iTrader: (0)

@shawnsheridan & @skalberti

can you give your views about how the anti dazzle is working? I want to make sure all the situations I might see before I code it.

I think you already talked about these lot of times, but couldn't find those. If you can spot down your words here. I think if @opasha can update the OP with those comments under that, it would be helpful for people who are planning into it.
Appreciate 0
      09-28-2014, 10:58 AM   #104
r33_RGSport
Major General
r33_RGSport's Avatar
United_States
1047
Rep
7,067
Posts

Drives: G30 540i / 997.1 C4S / i3 REx
Join Date: Oct 2009
Location: So. Cal

iTrader: (2)

Quote:
Originally Posted by Hang0ver View Post
@opasha & @r33 :

can you check where you have the auto start stop OFF by default in comfort mode. in the cheat sheet its noted that it can be found in 3000. But I think I saw it in 3026. Atleast for me.
@Hang0ver, it is by default to follow the last setting already. I think that is better setting that OFF by default.
__________________
Appreciate 0
      09-28-2014, 11:09 AM   #105
Hang0ver
Second Lieutenant
Hang0ver's Avatar
12
Rep
208
Posts

Drives: 2015 X5 35i
Join Date: Aug 2014
Location: Maryland

iTrader: (0)

Quote:
Originally Posted by r33 View Post
@Hang0ver, it is by default to follow the last setting already. I think that is better setting that OFF by default.
I kind of had that thought too...But, the number of times I need that off would be far more than the number of times I want that to be on. That made me think to make it OFF by default. It would have been better if it allows us to turn that off in ECO PRO.

People argue that ECO PRO is for saving fuel. But we might want to save fuel by reducing the amount it allows us to accelerate where ECO PRO does that.
Appreciate 0
      09-28-2014, 06:00 PM   #106
opasha
Brigadier General
opasha's Avatar
833
Rep
3,991
Posts

Drives: 2014 BMW X5 50i
Join Date: Apr 2014
Location: Maryland

iTrader: (0)

Quote:
Originally Posted by Hang0ver View Post
@opasha & @r33 :

can you check where you have the auto start stop OFF by default in comfort mode. in the cheat sheet its noted that it can be found in 3000. But I think I saw it in 3026. Atleast for me.
Quote:
Originally Posted by Hang0ver View Post
I kind of had that thought too...But, the number of times I need that off would be far more than the number of times I want that to be on. That made me think to make it OFF by default. It would have been better if it allows us to turn that off in ECO PRO.

People argue that ECO PRO is for saving fuel. But we might want to save fuel by reducing the amount it allows us to accelerate where ECO PRO does that.

I don't remember if it's 3000. I think 3026 might be the right location because remember how I explained different vehicles have different locations. I pulled that code from the F10 thread. The coding was the same but I forgot the section was different. As long as the exact code name matches up then that is the correct one. I'll correct it in the OP after you code it. I don't have time right now to check it on my car. Let me know. Thanks .

Also regarding ECO-PRO, there is no way to turn it off by default in this mode. I always drive in ECO-PRO with Auto-Start/Stop OFF as well. After reading the impact on the engine, I find Auto-Start/Stop to be completely pointless and don't like the lag it creates. Let's say someone is coming at you from behind real fast and you want to get out of the way....that's one extra second the stupid feature takes away from you being able to move...not worth it in my opinion, so I just turn it off every time with the button in ECO-PRO. I'm still saving gas.
__________________
2014 X5 50i X-Line // Mineral White
Appreciate 0
      09-28-2014, 08:33 PM   #107
shawnsheridan
Lieutenant General
shawnsheridan's Avatar
United_States
1402
Rep
13,544
Posts

Drives: 2011 535i M-Sport
Join Date: Feb 2010
Location: Houston, TX

iTrader: (0)

Garage List
Quote:
Originally Posted by Hang0ver View Post
@shawnsheridan & @skalberti

can you give your views about how the anti dazzle is working? I want to make sure all the situations I might see before I code it.

I think you already talked about these lot of times, but couldn't find those. If you can spot down your words here. I think if @opasha can update the OP with those comments under that, it would be helpful for people who are planning into it.
I personally have not coded Glare Free High Beams (aka Anti Dazzle) as my F10 does not have High Beam Assist. Since I do have Adaptive Headlights, I could still code Variable Light Distribution, but I just never bothered. Many people have coded both, and swear they work great though, and it is very simple to do. Just remove from FA both S8S4A, which disables Variable Light Distribution, and S5APA, which Disables Glare Free High Beams, and VO Code Headlight module (BDC and for LED Lights LHM & TMS too) and Camera module (KAFAS or FLA).
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Appreciate 1
      09-28-2014, 09:23 PM   #108
opasha
Brigadier General
opasha's Avatar
833
Rep
3,991
Posts

Drives: 2014 BMW X5 50i
Join Date: Apr 2014
Location: Maryland

iTrader: (0)

Quote:
Originally Posted by shawnsheridan View Post
I personally have not coded Glare Free High Beams (aka Anti Dazzle) as my F10 does not have High Beam Assist. Since I do have Adaptive Headlights, I could still code Variable Light Distribution, but I just never bothered. Many people have coded both, and swear they work great though, and it is very simple to do. Just remove from FA both S8S4A, which disables Variable Light Distribution, and S5APA, which Disables Glare Free High Beams, and VO Code Headlight module (BDC and for LED Lights LHM & TMS too) and Camera module (KAFAS or FLA).
Shawn, is this the variable light distribution in action?

__________________
2014 X5 50i X-Line // Mineral White
Appreciate 0
      09-28-2014, 09:59 PM   #109
Hang0ver
Second Lieutenant
Hang0ver's Avatar
12
Rep
208
Posts

Drives: 2015 X5 35i
Join Date: Aug 2014
Location: Maryland

iTrader: (0)

Quote:
Originally Posted by shawnsheridan View Post
I personally have not coded Glare Free High Beams (aka Anti Dazzle) as my F10 does not have High Beam Assist. Since I do have Adaptive Headlights, I could still code Variable Light Distribution, but I just never bothered. Many people have coded both, and swear they work great though, and it is very simple to do. Just remove from FA both S8S4A, which disables Variable Light Distribution, and S5APA, which Disables Glare Free High Beams, and VO Code Headlight module (BDC and for LED Lights LHM & TMS too) and Camera module (KAFAS or FLA).
Thanks shawn.. Below is the steps from OP. Want to make sure I am doing it right. You mentioned to VO code LHM & TMS which are not mentioned in OP. Is that right?

Remove 5AP and 8S4 from the VO and CODE (right click the folder and select code) KAFAS2 and BDC_BODY. If you don't have the KAFAS2 folder under ECU in ESYS, that means you do not have the KAFAS camera but most likely you have the HBA stand-alone camera below your rear view mirror if you have LED Lighting Package. KAFAS2 folder is usually present in vehicles with Lane Assist Package. If this is the case, you must CODE FLA3 folder instead.
Appreciate 0
      09-28-2014, 10:07 PM   #110
Hang0ver
Second Lieutenant
Hang0ver's Avatar
12
Rep
208
Posts

Drives: 2015 X5 35i
Join Date: Aug 2014
Location: Maryland

iTrader: (0)

Quote:
Originally Posted by opasha View Post
Shawn, is this the variable light distribution in action?
...
I don't think so. I think the ones in the video is showing anti dazzle effect.

Found this online.

Introduced in 2003 - BMW adaptive headlights system ensures the headlights follow the curve of the road, especially useful at night where there are no street lamps.

Introduced in 2005 - High-beam Assist automatically detects the presence of other cars and switches back to dipped beam, then reverting to high beam once the other vehicle has passed, or been passed.

Introduced in 2006 - BMW Night Vision uses Far Infra Red technology to detect heat-emitting objects further up the road than the headlights could reach, providing early warning of pedestrians, or uniquely in Australia, roaming wildlife such as kangaroos, and helping to prevent animal strikes.

Introduced in 2007 - Variable Light Distribution technology varies the shape of the illumination cast by the headlamp, depending on driving conditions. The aim is to enhance safety at various speeds, on different types of roads at night, or in poor weather.

Last edited by Hang0ver; 09-29-2014 at 06:59 AM.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 10:59 PM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST