BMW X5 and X6 Forum 2014-Current
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Post Reply
 
Thread Tools Search this Thread
      07-29-2014, 05:59 AM   #67
NPickles
Lieutenant
United Kingdom
38
Rep
450
Posts

Drives: F15 40D SE Space Grey/Terra
Join Date: Mar 2014
Location: Nottingham UK

iTrader: (0)

Quote:
Originally Posted by NPickles View Post
I'll have to check mine now, I'll let you know what I find in the morning when I check them.
Checked mine this morning and pretty much spot on though the fronts were a little more off than the rears. Used a digital tyre inflator at a local garage to get to 32psi front and 35psi rear, reset the TPMS and drove around a bit until the pressures & temps came back up (took ages by the way) and the rears were within one psi of 35 but the fronts were showing only 30psi even though the tyre temps had risen buy about 3 degrees C so I would have expected them to be showing over 32psi.

I will double check them on another local digital tyre inflator once the temps have stabilised.
Appreciate 0
      07-30-2014, 10:39 AM   #68
BKMK5
First Lieutenant
11
Rep
324
Posts

Drives: 2014 X5 50i M Sport
Join Date: Jan 2009
Location: NY

iTrader: (0)

Got the car back last night at 7pm and it is back in the shop by 7:30 am this morning.

At 3am the alarm went off. Gave BMW the benefit of the doubt and thought "It is 'fixed', it must be a squirrel that caused it", so I unlock and lock it from my front door. 15 minutes later it goes off again, waking up my 1 and 2 year olds. Go outside to find 'Hood Ajar' on the dash.

So glad I deposited my BMWCCA $1k check yesterday but I'm fed up with the terrible service I'm receiving and the truck as a whole.
__________________
2014 BMW X5 50i M Sport
TOTALED-2013 Mercedes-Benz GL450
SOLD-2013 Porsche Cayenne S
SOLD-2011.5 ///M3 Sedan ZCP
SOLD-2008 E90 335i Sport
Appreciate 0
      07-30-2014, 11:39 AM   #69
Alan l.
Major General
Alan l.'s Avatar
1110
Rep
6,394
Posts

Drives: 2016 F85M
Join Date: Jun 2009
Location: United States

iTrader: (9)

I hope you aren't bringing your car to Life Quality BMW in BK. They are the worst dealership around here. Real bunch of monkeys working cars there. I live close by but I still bring my car out to LI for service.

Alan
__________________
Appreciate 0
      07-30-2014, 11:42 AM   #70
BKMK5
First Lieutenant
11
Rep
324
Posts

Drives: 2014 X5 50i M Sport
Join Date: Jan 2009
Location: NY

iTrader: (0)

Quote:
Originally Posted by Alan l. View Post
I hope you aren't bringing your car to Life Quality BMW in BK. They are the worst dealership around here. Real bunch of monkeys working cars there. I live close by but I still bring my car out to LI for service.

Alan
Habberstad BMW. I bought my 335i there and after the Navigation issues I had there I ended up buying and servicing my M3 at Competition in Smithtown. Only bought the X5 and servicing it at Habberstad since they were the only ones with a decent X5 for immediate purchase last month when my GL got totaled. After drinking the BMW Koolaid for too long I am strongly considering going with a C63 next year or if my X5 turns out to be a lemon go back to Porsche.
__________________
2014 BMW X5 50i M Sport
TOTALED-2013 Mercedes-Benz GL450
SOLD-2013 Porsche Cayenne S
SOLD-2011.5 ///M3 Sedan ZCP
SOLD-2008 E90 335i Sport
Appreciate 0
      07-31-2014, 08:25 AM   #71
gigliosa
Registered
Italy
0
Rep
3
Posts

Drives: X5 3.0d Xdrive (F15)
Join Date: Mar 2014
Location: Roma - Italy

iTrader: (0)

Hello everyone,

until now I have done over 5K miles in highway and I'm worried about the performances of the Gear and of the Turbo, when it has to downshift, mainly from 6^-7^ to 5^-6^ in Drive mode, to improve the overtaking of another car.

To have the downshift, I've to put the accelarator pedal all down, the engine go up to over 3K+ turns and there is 1-2 seconds in Turbo Lab.

It's the same in Confort and Sport mode.

It seem as an 80s years turbo!!! (but today I'm not mode old as in the 80s ...)

I've previous experience with similar engines and gears from Audi and the engine power was every at my disposal when requested, in microsecs.

any comments?

(sorry for my english, I'm italian )
Appreciate 0
      07-31-2014, 09:59 AM   #72
Armen383
First Lieutenant
Armen383's Avatar
Cyprus
47
Rep
336
Posts

Drives: Mercedes-Benz E63S
Join Date: Jan 2014
Location: Limassol

iTrader: (0)

Back to the squeaky bolsters issue - the dealer simply greased something inside the seat on the right hand side (from where the sound came) - issue completely gone (hopefully forever).
Appreciate 0
      07-31-2014, 10:48 AM   #73
1230vani
Lieutenant Colonel
1230vani's Avatar
No_Country
180
Rep
1,901
Posts

Drives: F15 30d Msport
Join Date: Feb 2009
Location: N/A

iTrader: (0)

Dealer said that the error messages I get:

1) cruise control error (I get it every time I start the car)

2) chasis error (happens at time, need to restart the car and it goes away)

Service tells me they are software errors? Sounds strange, but they say they do not have a software update yet, expected in 2 weeks and they will do it for free overnight under warranty. Now, when I had my old car (E71) I heard that you DO NOT want to do a software update on your car. Now my question is does it make sense what they say and is it OK they run a software update or am I then looking at some other problem. I had a newer loaner and noticed that there are very small difference in the NAVI for example, but I do not like them (e.g. to shut off additional info on the navi screen you need to press the idrive and the info on radio and such dissapears, on this newer build you go through another small menu to remove additional info). I did not play around much and do not know if there are other differences.

On a side note I want to do a BMW OEM performance upgrade (power) and the dude at the service is telling me I have to upgrade the brakes then as well? I do not think that he is right. I planned to install brakes when they are anyways due for a change.
Appreciate 0
      07-31-2014, 11:29 AM   #74
buckeyewalt
Lieutenant
22
Rep
407
Posts

Drives: 2014 X5 50i
Join Date: Feb 2012
Location: West Tennessee

iTrader: (0)

I still have issues with my HUD. My profile ( as well as my wife) is not recognized for the HUD height only and reverts to the default mode when the other driver gets into the vehicle. All other functions on our profiles are recognized and changed to our setting when we drive the vehicle, except for the HUD height. The dealer said it probably is the key FOB since everything else is picked up. Oh by the way, when I press my profile seat number, the HUD height is adjusted to the correct height. Only the FOB does not recognize the HUD height.
Appreciate 0
      07-31-2014, 11:52 AM   #75
atomic80
Lieutenant
196
Rep
522
Posts

Drives: 997TT
Join Date: Jan 2008
Location: Bellevue, WA

iTrader: (0)

Quote:
Originally Posted by 1230vani View Post
Dealer said that the error messages I get:

1) cruise control error (I get it every time I start the car)

2) chasis error (happens at time, need to restart the car and it goes away)

Service tells me they are software errors? Sounds strange, but they say they do not have a software update yet, expected in 2 weeks and they will do it for free overnight under warranty. Now, when I had my old car (E71) I heard that you DO NOT want to do a software update on your car. Now my question is does it make sense what they say and is it OK they run a software update or am I then looking at some other problem. I had a newer loaner and noticed that there are very small difference in the NAVI for example, but I do not like them (e.g. to shut off additional info on the navi screen you need to press the idrive and the info on radio and such dissapears, on this newer build you go through another small menu to remove additional info). I did not play around much and do not know if there are other differences.

On a side note I want to do a BMW OEM performance upgrade (power) and the dude at the service is telling me I have to upgrade the brakes then as well? I do not think that he is right. I planned to install brakes when they are anyways due for a change.
The chassis error came up on mine and they also told me that it was a software issue and updated mine but that did NOT fix the problem. They eventually traced it to a defective Vertical Acceleration Sensor being bad and had to replace that. That fixed the chassis issue so be sure to mention that to your dealership. I haven't had issues with the cruise control however though.
Appreciate 0
      07-31-2014, 11:58 AM   #76
atomic80
Lieutenant
196
Rep
522
Posts

Drives: 997TT
Join Date: Jan 2008
Location: Bellevue, WA

iTrader: (0)

Quote:
Originally Posted by Armen383 View Post
Back to the squeaky bolsters issue - the dealer simply greased something inside the seat on the right hand side (from where the sound came) - issue completely gone (hopefully forever).
Mine also squeaked too..they replaced both bolsters and the sound is gone.
Appreciate 0
      07-31-2014, 12:47 PM   #77
1230vani
Lieutenant Colonel
1230vani's Avatar
No_Country
180
Rep
1,901
Posts

Drives: F15 30d Msport
Join Date: Feb 2009
Location: N/A

iTrader: (0)

Quote:
Originally Posted by atomic80 View Post
The chassis error came up on mine and they also told me that it was a software issue and updated mine but that did NOT fix the problem. They eventually traced it to a defective Vertical Acceleration Sensor being bad and had to replace that. That fixed the chassis issue so be sure to mention that to your dealership. I haven't had issues with the cruise control however though.
THANKS A LOT!!!! As always, this forum is the source of information.
Appreciate 0
      07-31-2014, 12:57 PM   #78
bluelodge400
Private
bluelodge400's Avatar
19
Rep
98
Posts

Drives: '15 X5 50i, '16 Cayenne Turbo
Join Date: Nov 2013
Location: Hillsborough, CA

iTrader: (0)

Quote:
Originally Posted by BKMK5 View Post
Got the car back last night at 7pm and it is back in the shop by 7:30 am this morning.

At 3am the alarm went off. Gave BMW the benefit of the doubt and thought "It is 'fixed', it must be a squirrel that caused it", so I unlock and lock it from my front door. 15 minutes later it goes off again, waking up my 1 and 2 year olds. Go outside to find 'Hood Ajar' on the dash.

So glad I deposited my BMWCCA $1k check yesterday but I'm fed up with the terrible service I'm receiving and the truck as a whole.
This happens with mine.
Now when I lock it, I press the lock button twice on the remote which disables the motion sensor in the interior cabin. Until BMW finds a fix for you, I would suggest trying that.
Appreciate 0
      07-31-2014, 08:05 PM   #79
BKMK5
First Lieutenant
11
Rep
324
Posts

Drives: 2014 X5 50i M Sport
Join Date: Jan 2009
Location: NY

iTrader: (0)

Quote:
Originally Posted by bluelodge400 View Post
This happens with mine.
Now when I lock it, I press the lock button twice on the remote which disables the motion sensor in the interior cabin. Until BMW finds a fix for you, I would suggest trying that.
I doubt its a motion sensor when it says its an open hood. 33 days of ownership, in the shop for 11 of them. BMWNA better have some news for me tomorrow.
__________________
2014 BMW X5 50i M Sport
TOTALED-2013 Mercedes-Benz GL450
SOLD-2013 Porsche Cayenne S
SOLD-2011.5 ///M3 Sedan ZCP
SOLD-2008 E90 335i Sport
Appreciate 0
      08-05-2014, 08:32 AM   #80
BKMK5
First Lieutenant
11
Rep
324
Posts

Drives: 2014 X5 50i M Sport
Join Date: Jan 2009
Location: NY

iTrader: (0)

Latest warnings. Tomorrow will be day 12. Its also the last day(3- 5 business days) before a BMW resolution specialist is to get back to me on a buy back. Otherwise it is time to lawyer up.
Attached Images
 
__________________
2014 BMW X5 50i M Sport
TOTALED-2013 Mercedes-Benz GL450
SOLD-2013 Porsche Cayenne S
SOLD-2011.5 ///M3 Sedan ZCP
SOLD-2008 E90 335i Sport
Appreciate 0
      08-05-2014, 05:26 PM   #81
CatFlap
Lieutenant
United Kingdom
12
Rep
424
Posts

Drives: ...
Join Date: Aug 2012
Location: UK

iTrader: (0)

Quote:
Originally Posted by cc3 View Post
Heard a friend of a friend whose new X5 has been off the road for 6 weeks awaiting parts after transmission failure. His car had been recalled but given all clear by UK dealer only for the transmission to fail 2 days later. Anyone aware of any recall that is transmission related??
Do you know what the transmission problem was? I've got some strange noises coming from under the my X5d on the overrun at low speeds. It also makes similar whining noises on light throttle at low speeds too. My transmission sometimes sounds like it's done 200,000 miles!
__________________
X5 F15 - gone after 5 months!
Appreciate 0
      08-05-2014, 06:23 PM   #82
Heden
Private
4
Rep
55
Posts

Drives: Audi RS6 MY2016
Join Date: Nov 2013
Location: London

iTrader: (0)

The rattle from the tailgate, could anyone advise what has been done to address the issue? Both from the dealer and DIY would be great.
Appreciate 0
      08-06-2014, 11:06 AM   #83
r33_RGSport
Major General
r33_RGSport's Avatar
United_States
1047
Rep
7,067
Posts

Drives: G30 540i / 997.1 C4S / i3 REx
Join Date: Oct 2009
Location: So. Cal

iTrader: (2)

Follow up on my tire pressure issues.
The dealer checked the pressure using their digital gauge and it shows the correct number between the actual and what shown on the i-Drive. So, that concludes that I need to get better tire gauge.
But with that, that's mean the dealer didn't put the correct tire pressure as indicated on the door jam. I got angry at the SA since he didn't get it right at the first place and wasted my time.
__________________
Appreciate 0
      08-06-2014, 12:56 PM   #84
BKMK5
First Lieutenant
11
Rep
324
Posts

Drives: 2014 X5 50i M Sport
Join Date: Jan 2009
Location: NY

iTrader: (0)

When you guys push the 'Intelligent Safety Button' does your pedestrian warning stay checked? I can check it, leave the menu and go back in and its unchecked. I can shut the car off, turn it back on and its NEVER on. Is that by design or is my truck still messed up.

__________________
2014 BMW X5 50i M Sport
TOTALED-2013 Mercedes-Benz GL450
SOLD-2013 Porsche Cayenne S
SOLD-2011.5 ///M3 Sedan ZCP
SOLD-2008 E90 335i Sport
Appreciate 0
      08-06-2014, 01:48 PM   #85
1230vani
Lieutenant Colonel
1230vani's Avatar
No_Country
180
Rep
1,901
Posts

Drives: F15 30d Msport
Join Date: Feb 2009
Location: N/A

iTrader: (0)

Quote:
Originally Posted by Heden
The rattle from the tailgate, could anyone advise what has been done to address the issue? Both from the dealer and DIY would be great.
BMW service greased up everything in the back and tightened the lock. Noise gone, strange noise when locking the trunk (brief).
Appreciate 0
      08-06-2014, 03:08 PM   #86
Heden
Private
4
Rep
55
Posts

Drives: Audi RS6 MY2016
Join Date: Nov 2013
Location: London

iTrader: (0)

Quote:
Originally Posted by 1230vani View Post
BMW service greased up everything in the back and tightened the lock. Noise gone, strange noise when locking the trunk (brief).
Thanks very much. Would have been even better if there would've been a service bulletin issued. Always easier to show the service department a descriptive letter with a BMW logo on it
Appreciate 0
      08-06-2014, 03:09 PM   #87
BKMK5
First Lieutenant
11
Rep
324
Posts

Drives: 2014 X5 50i M Sport
Join Date: Jan 2009
Location: NY

iTrader: (0)

Here is the video of what I'm describing. If anyone can confirm this is normal, that would be helpful. Also note there were some NSFW words spoken on the radio while recording so lower your volume...

__________________
2014 BMW X5 50i M Sport
TOTALED-2013 Mercedes-Benz GL450
SOLD-2013 Porsche Cayenne S
SOLD-2011.5 ///M3 Sedan ZCP
SOLD-2008 E90 335i Sport
Appreciate 0
      08-07-2014, 02:17 AM   #88
1230vani
Lieutenant Colonel
1230vani's Avatar
No_Country
180
Rep
1,901
Posts

Drives: F15 30d Msport
Join Date: Feb 2009
Location: N/A

iTrader: (0)

Quote:
Originally Posted by Heden
Quote:
Originally Posted by 1230vani View Post
BMW service greased up everything in the back and tightened the lock. Noise gone, strange noise when locking the trunk (brief).
Thanks very much. Would have been even better if there would've been a service bulletin issued. Always easier to show the service department a descriptive letter with a BMW logo on it
They have it in their database, at least one service manager at the dealer has access, they now and document all this stuff. I will ask to get for you, hope they do
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 10:50 PM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST