BMW X5 and X6 Forum 2014-Current
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Post Reply
 
Thread Tools Search this Thread
      04-29-2014, 04:28 AM   #1
ljxrayman
Private
0
Rep
67
Posts

 
Drives: 2014 X5 M Sport Mineral White
Join Date: Feb 2014
Location: Richmond, BC

iTrader: (0)

Please Help! Coding Issue!! LED Strip Gone

After coding using the cheat sheet r33 provided, I was able to get all the features listed in the sheet working. However, my interior LED lights are gone!!!! And both driver side and passenger side' interior FOOT LIGHTING are also gone! See pictures. I didn't touch any other module other than the modules listed in the sheet.

Now I'm desperate....could someone help me please....
Attached Images
  

Last edited by ljxrayman; 04-29-2014 at 05:00 AM.
Appreciate 0
      04-29-2014, 05:06 AM   #2
opasha
Colonel
opasha's Avatar
99
Rep
2,531
Posts

 
Drives: 2014 BMW X5 50i
Join Date: Apr 2014
Location: Maryland

iTrader: (0)

for now, let the car sleep. then test tomorrow and go into lighting settings from the iDrive menu. what was the last thing you coded? that might help some coders here diagnose what you messed up or accidentally saved.
Appreciate 0
      04-29-2014, 05:21 AM   #3
ljxrayman
Private
0
Rep
67
Posts

 
Drives: 2014 X5 M Sport Mineral White
Join Date: Feb 2014
Location: Richmond, BC

iTrader: (0)

I used r33's cheat sheet link in the following:
https://docs.google.com/spreadsheets...9s4/edit#gid=0

I coded almost everything except the HUD Turn Signal and the Seat Heating & Ventilating feature. I knew exactly how the procedure works:
1. Read the FA
2. read the ECU
3. Read Code for the SVT
4. Code the desire module by editing the FDL
5: Save the editing
6. Coding FDL

The last thing I coded was the last one, listed "DON'T KNOW". After that, I realized my interior LED Strips were all gone!! Then I decoded everything one at a time but the Led strips were still not coming up. Please help me...
Appreciate 0
      04-29-2014, 05:25 AM   #4
ljxrayman
Private
0
Rep
67
Posts

 
Drives: 2014 X5 M Sport Mineral White
Join Date: Feb 2014
Location: Richmond, BC

iTrader: (0)

Quote:
Originally Posted by opasha View Post
for now, let the car sleep. then test tomorrow and go into lighting settings from the iDrive menu. what was the last thing you coded? that might help some coders here diagnose what you messed up or accidentally saved.
Haha...you are the man!

The car resolved the problem it selfs! After 20 mins sleep, all the lights came back on!

Thank you~~Muahhhhh
Appreciate 0
      04-29-2014, 11:09 AM   #5
wdimagineer
Captain
wdimagineer's Avatar
United_States
27
Rep
998
Posts

 
Drives: 2014 X5 xDrive50i ZMM
Join Date: Nov 2011
Location: San Francisco, CA

iTrader: (0)

Ambient lighting disappears whenever you code BDC. Allow the car to sleep. The module reinitializes the LED lamps on the car's bus during this process.
__________________
Current: Bimmerpost Featured 2014 X5 xDrive50i M Sport Alpine White/Mocha - M Performance, Euro Tail Lights, Traffic Jam Assist, 6WB, and more...
Past: 2014 Jeep SRT 2013 Tesla Model S P85+ Bimmerpost Featured 2013 F10 M5 2012 550 xDrive 2011 M3 ZCP
Appreciate 0
      04-29-2014, 11:47 AM   #6
ljxrayman
Private
0
Rep
67
Posts

 
Drives: 2014 X5 M Sport Mineral White
Join Date: Feb 2014
Location: Richmond, BC

iTrader: (0)

Quote:
Originally Posted by wdimagineer
Ambient lighting disappears whenever you code BDC. Allow the car to sleep. The module reinitializes the LED lamps on the car's bus during this process.
Again, thanks for the tips! Without this thread and your help, I can never get this coding done.
Love you guys! Especially for r33...for compilling everything using his own time to share this.
Appreciate 0
      04-29-2014, 02:54 PM   #7
opasha
Colonel
opasha's Avatar
99
Rep
2,531
Posts

 
Drives: 2014 BMW X5 50i
Join Date: Apr 2014
Location: Maryland

iTrader: (0)

Quote:
Originally Posted by ljx*****n View Post
Haha...you are the man!

The car resolved the problem it selfs! After 20 mins sleep, all the lights came back on!

Thank you~~Muahhhhh
patience is a virtue
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:20 PM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST