BMW X5 and X6 Forum 2014-Current
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Post Reply
 
Thread Tools Search this Thread
      01-19-2018, 07:13 PM   #551
Stev_chu
Private First Class
Stev_chu's Avatar
86
Rep
140
Posts

Drives: 2015 BMW X5
Join Date: Oct 2017
Location: NEW YORK

iTrader: (0)

Quote:
Originally Posted by admranger View Post
So today I got a brake system error on my 40e. Cluster lit up w/lots of lights (ABS, traction control, etc., etc.) and I got lots of warnings about brakes being iffy and collision avoidance, pedestrian avoidance, etc. were inactive. Brake pedal was super long and soft.

Fortunately, I was about a 1/4 mile from the house. Pulled into the garage and parked it. Had to move it a short time later and all the warnings were gone. Ummm, ok...

Hit the check control and there was no errors found.

I guess I'll see what happens when I drive it to the airport tonight to pick my wife up.
With most bmw errors will occur while the vehicle is being driven..i had the experience before..yes please keep us posted
Appreciate 1
      01-19-2018, 10:25 PM   #552
admranger
Curmudgeon
admranger's Avatar
United_States
891
Rep
2,346
Posts

Drives: 2011 M3, 2016 X5 40e
Join Date: May 2011
Location: Alexandria, VA

iTrader: (0)

Quote:
Originally Posted by Stev_chu View Post
With most bmw errors will occur while the vehicle is being driven..i had the experience before..yes please keep us posted
Drove it to the airport and back with no issues. Everything was normal.
__________________
'11 E90 M3, Mebourne/Black/Fox Red/Black, 6MT, PP2, heated seats, moonroof, split folding rear seats, iPod/USB adapter, Dinan F sway bar, Arc-8's, Technic harness, JL XD 6/600.

'16 X5 40e, Mineral White/Black Dakota Leather, ZLL, ZCW, ZDA, ZDB, ZPP, multi contour seats, HK
Appreciate 0
      01-20-2018, 01:55 AM   #553
Stev_chu
Private First Class
Stev_chu's Avatar
86
Rep
140
Posts

Drives: 2015 BMW X5
Join Date: Oct 2017
Location: NEW YORK

iTrader: (0)

Quote:
Originally Posted by admranger View Post
Quote:
Originally Posted by Stev_chu View Post
With most bmw errors will occur while the vehicle is being driven..i had the experience before..yes please keep us posted
Drove it to the airport and back with no issues. Everything was normal.
Weird..anyway it's all good perhaps..good luck and thanks for sharing
Appreciate 0
      01-20-2018, 10:54 AM   #554
admranger
Curmudgeon
admranger's Avatar
United_States
891
Rep
2,346
Posts

Drives: 2011 M3, 2016 X5 40e
Join Date: May 2011
Location: Alexandria, VA

iTrader: (0)

Quote:
Originally Posted by Stev_chu View Post
Weird..anyway it's all good perhaps..good luck and thanks for sharing
Could have been some crud from all the salt on the roads that's now splattered everywhere.

Tried to get it washed but the car wash guy said the rear wheels/tires were too wide (it's a lease, it is gonna go through car washes). Going to look for a hand spray type car wash today if I can.
__________________
'11 E90 M3, Mebourne/Black/Fox Red/Black, 6MT, PP2, heated seats, moonroof, split folding rear seats, iPod/USB adapter, Dinan F sway bar, Arc-8's, Technic harness, JL XD 6/600.

'16 X5 40e, Mineral White/Black Dakota Leather, ZLL, ZCW, ZDA, ZDB, ZPP, multi contour seats, HK
Appreciate 1
      01-20-2018, 11:29 PM   #555
Stev_chu
Private First Class
Stev_chu's Avatar
86
Rep
140
Posts

Drives: 2015 BMW X5
Join Date: Oct 2017
Location: NEW YORK

iTrader: (0)

Quote:
Originally Posted by admranger View Post
Quote:
Originally Posted by Stev_chu View Post
Weird..anyway it's all good perhaps..good luck and thanks for sharing
Could have been some crud from all the salt on the roads that's now splattered everywhere.

Tried to get it washed but the car wash guy said the rear wheels/tires were too wide (it's a lease, it is gonna go through car washes). Going to look for a hand spray type car wash today if I can.
I've been reading many posts regarding with the brutal weathers this winter and causing the vehicle to go coo coo at some point..I'm really hoping is the cold weather..with all these new tech with modern cars it can be very smart or confusing..good luck
Appreciate 0
      01-21-2018, 07:45 PM   #556
admranger
Curmudgeon
admranger's Avatar
United_States
891
Rep
2,346
Posts

Drives: 2011 M3, 2016 X5 40e
Join Date: May 2011
Location: Alexandria, VA

iTrader: (0)

Quote:
Originally Posted by Stev_chu View Post
I've been reading many posts regarding with the brutal weathers this winter and causing the vehicle to go coo coo at some point..I'm really hoping is the cold weather..with all these new tech with modern cars it can be very smart or confusing..good luck
i think I may have stumbled onto something. History has shown that when a battery gets low on a BMW, the dash can light up with weird errors. I finally remembered this this afternoon and put the battery charger on the 40e (charging the normal car battery). It jumped to 3 amps (on the 2 amp setting). This after driving it quite a bit on the engine on Saturday.

We'll see if things hold and the lights are a thing of the past.
__________________
'11 E90 M3, Mebourne/Black/Fox Red/Black, 6MT, PP2, heated seats, moonroof, split folding rear seats, iPod/USB adapter, Dinan F sway bar, Arc-8's, Technic harness, JL XD 6/600.

'16 X5 40e, Mineral White/Black Dakota Leather, ZLL, ZCW, ZDA, ZDB, ZPP, multi contour seats, HK
Appreciate 1
      01-21-2018, 10:43 PM   #557
Stev_chu
Private First Class
Stev_chu's Avatar
86
Rep
140
Posts

Drives: 2015 BMW X5
Join Date: Oct 2017
Location: NEW YORK

iTrader: (0)

Quote:
Originally Posted by admranger View Post
Quote:
Originally Posted by Stev_chu View Post
I've been reading many posts regarding with the brutal weathers this winter and causing the vehicle to go coo coo at some point..I'm really hoping is the cold weather..with all these new tech with modern cars it can be very smart or confusing..good luck
i think I may have stumbled onto something. History has shown that when a battery gets low on a BMW, the dash can light up with weird errors. I finally remembered this this afternoon and put the battery charger on the 40e (charging the normal car battery). It jumped to 3 amps (on the 2 amp setting). This after driving it quite a bit on the engine on Saturday.

We'll see if things hold and the lights are a thing of the past.
Good points..please keep us all posted
Appreciate 0
      01-27-2018, 07:03 AM   #558
mnx5er
Private First Class
41
Rep
113
Posts

Drives: 2015 BMW X5 3.5i
Join Date: Feb 2016
Location: Minneapolis, MN

iTrader: (0)

iDrive 6 in the 2018 X5 is flaky - actually flakier than previous versions of iDrive. I am having three problems with it.

1. Heads-up display does not turn on every month or so. Only can me remedied by parking the car and letting it sit for a while. Everything else I've tried won't turn it back on

2. Preset setting for the radio/SAT is lost and it goes back to the last station you had on next start. For example, if I had a FM station on, when I start the X5 it now displays all FM stations when I try to change stations, not the presets I had it on. This problem is now happening a few times a week at least.

3. Forgets where the iDrive screen was. I usually have NAV and Entertainment on the screen. Most of the time it forgets this and goes back to the main tiles screen when I start the X5 again. Note iDrive 5 also was great at forgetting this last setting.

4. Crashes - three in four months. Entire iDrive system goes blank while driving and you have to wait for it to reboot. Not a fun thing to go through the first time. My last 2016 X5 with iDrive 5 sadly had the same problem.

Overall pretty sad reliability for iDrive. I have had a number of X5s and while the overall reliability seems to be improving, every new version of iDrive gets worse.

Time to take it in and get it updated. I wish BMW allowed owners to update the thing. Appears the updates you can do only impact phone and media connectivity, not the entire iDrive system.
Appreciate 0
      01-27-2018, 05:42 PM   #559
CeeTeeX5
Major
760
Rep
1,100
Posts

Drives: 2018 X5 xDrive35i M-Sport
Join Date: Apr 2008
Location: Bellevue, WA

iTrader: (0)

Quote:
Originally Posted by mnx5er View Post


2. Preset setting for the radio/SAT is lost and it goes back to the last station you had on next start. For example, if I had a FM station on, when I start the X5 it now displays all FM stations when I try to change stations, not the presets I had it on. This problem is now happening a few times a week at least.
I can't say I've experienced all the issues you've had but I did experience this and was able to find a solution for it. I did a bunch of things at once so I'm not 100% sure which fixed it but give these a try.

1. Unlock your car with the key fob
2. Set the seat memory
3. Add a radio station or SAT station to preset and make sure you have presets checked in Media
4. set the seat memory again
5. Exit car and lock with the key fob

Be sure to also only have 1 of the keys on you. The above steps solved the issue for me. Mine was kicking me back to the whole SAT catalog periodically. I think there must be some bug where when using comfort access to unlock/lock the car it's not memorizing all the settings for your profile. I haven't had the issue re-occur after taking the above steps, whether I use the key fob or comfort access to unlock/lock the car. Hope this works for you!
Appreciate 0
      01-27-2018, 08:07 PM   #560
admranger
Curmudgeon
admranger's Avatar
United_States
891
Rep
2,346
Posts

Drives: 2011 M3, 2016 X5 40e
Join Date: May 2011
Location: Alexandria, VA

iTrader: (0)

Quote:
Originally Posted by CeeTeeX5 View Post
I can't say I've experienced all the issues you've had but I did experience this and was able to find a solution for it. I did a bunch of things at once so I'm not 100% sure which fixed it but give these a try.

1. Unlock your car with the key fob
2. Set the seat memory
3. Add a radio station or SAT station to preset and make sure you have presets checked in Media
4. set the seat memory again
5. Exit car and lock with the key fob

Be sure to also only have 1 of the keys on you. The above steps solved the issue for me. Mine was kicking me back to the whole SAT catalog periodically. I think there must be some bug where when using comfort access to unlock/lock the car it's not memorizing all the settings for your profile. I haven't had the issue re-occur after taking the above steps, whether I use the key fob or comfort access to unlock/lock the car. Hope this works for you!
I'm pretty sure this only works if you go commando and stand on your left foot only during the entire process. Key fob has to be in the right hand. Flat brimmed hat must be worn during steps 1 - 3, then turned into rally cap for steps 4-5. Easy.

Modern BMW's need an on/off button so we can just reboot them from time to time.
__________________
'11 E90 M3, Mebourne/Black/Fox Red/Black, 6MT, PP2, heated seats, moonroof, split folding rear seats, iPod/USB adapter, Dinan F sway bar, Arc-8's, Technic harness, JL XD 6/600.

'16 X5 40e, Mineral White/Black Dakota Leather, ZLL, ZCW, ZDA, ZDB, ZPP, multi contour seats, HK
Appreciate 0
      01-28-2018, 12:47 AM   #561
mnx5er
Private First Class
41
Rep
113
Posts

Drives: 2015 BMW X5 3.5i
Join Date: Feb 2016
Location: Minneapolis, MN

iTrader: (0)

Quote:
Originally Posted by CeeTeeX5 View Post
I can't say I've experienced all the issues you've had but I did experience this and was able to find a solution for it. I did a bunch of things at once so I'm not 100% sure which fixed it but give these a try.

1. Unlock your car with the key fob
2. Set the seat memory
3. Add a radio station or SAT station to preset and make sure you have presets checked in Media
4. set the seat memory again
5. Exit car and lock with the key fob

Be sure to also only have 1 of the keys on you. The above steps solved the issue for me. Mine was kicking me back to the whole SAT catalog periodically. I think there must be some bug where when using comfort access to unlock/lock the car it's not memorizing all the settings for your profile. I haven't had the issue re-occur after taking the above steps, whether I use the key fob or comfort access to unlock/lock the car. Hope this works for you!
Damn that is creative! I will try it tomorrow. I wonder if the same issue is causing my other stuff to be forgotten. We shall see!
Appreciate 0
      01-28-2018, 05:26 PM   #562
CeeTeeX5
Major
760
Rep
1,100
Posts

Drives: 2018 X5 xDrive35i M-Sport
Join Date: Apr 2008
Location: Bellevue, WA

iTrader: (0)

Quote:
Originally Posted by mnx5er View Post
Damn that is creative! I will try it tomorrow. I wonder if the same issue is causing my other stuff to be forgotten. We shall see!
Yah, let us know. I did some coding last night and noticed it defaulted to Sat again. Ran through the steps I outlined and has stayed on presets all day.
Appreciate 0
      01-28-2018, 09:03 PM   #563
mnx5er
Private First Class
41
Rep
113
Posts

Drives: 2015 BMW X5 3.5i
Join Date: Feb 2016
Location: Minneapolis, MN

iTrader: (0)

One day, so far so good. We'll see how it does through the week.
Appreciate 0
      02-01-2018, 03:09 PM   #564
DC F15
First Lieutenant
United_States
115
Rep
322
Posts

Drives: 2017 F15 35i Xdrive Space Grey
Join Date: Jul 2014
Location: Long Island ny

iTrader: (0)

So less than a year into owning my 2017 X5.... I start the car today only to be greeted by our good friend the "check engine light" the drivetrain malfunction warning... drive moderately...
my last car.. (F30 335i with the same N55 engine) gave me three years of uninteerrupted fun.... this one.. not even a year.. and here we go.

snagged an appt for today at 515 local time with a loaner for me. Service guy said it should ok to make the 20 minute trip to the dealership.. if it feels liek it can't make it.. stop and call for a tow.

keeping fingers crossed. Good thing is.. might as well get the 1 year service done while its there...
Appreciate 0
      02-01-2018, 04:54 PM   #565
CeeTeeX5
Major
760
Rep
1,100
Posts

Drives: 2018 X5 xDrive35i M-Sport
Join Date: Apr 2008
Location: Bellevue, WA

iTrader: (0)

Quote:
Originally Posted by DC F15 View Post
So less than a year into owning my 2017 X5.... I start the car today only to be greeted by our good friend the "check engine light" the drivetrain malfunction warning... drive moderately...
my last car.. (F30 335i with the same N55 engine) gave me three years of uninteerrupted fun.... this one.. not even a year.. and here we go.

snagged an appt for today at 515 local time with a loaner for me. Service guy said it should ok to make the 20 minute trip to the dealership.. if it feels liek it can't make it.. stop and call for a tow.

keeping fingers crossed. Good thing is.. might as well get the 1 year service done while its there...
Let us know what the diagnosis is!
Appreciate 0
      02-01-2018, 08:57 PM   #566
DC F15
First Lieutenant
United_States
115
Rep
322
Posts

Drives: 2017 F15 35i Xdrive Space Grey
Join Date: Jul 2014
Location: Long Island ny

iTrader: (0)

Quote:
Originally Posted by CeeTeeX5 View Post
Quote:
Originally Posted by DC F15 View Post
So less than a year into owning my 2017 X5.... I start the car today only to be greeted by our good friend the "check engine light" the drivetrain malfunction warning... drive moderately...
my last car.. (F30 335i with the same N55 engine) gave me three years of uninteerrupted fun.... this one.. not even a year.. and here we go.

snagged an appt for today at 515 local time with a loaner for me. Service guy said it should ok to make the 20 minute trip to the dealership.. if it feels liek it can't make it.. stop and call for a tow.

keeping fingers crossed. Good thing is.. might as well get the 1 year service done while its there...
Let us know what the diagnosis is!
Was so weird driving to the dealership in limp mode. It was like it was stuck in eco pro. I'm sure they will call me tomorrow with some initial prognosis. Looking forward to hearing from my super hot service advisor. Seriously. She makes my visits much more pleasant. Got put in a base x5. The leather felt strange. I miss my m sport steering wheel. And I thought HK sound was standard on the x5. I was wrong and man do I miss it.
But all first world problems aside. I'm hoping it's just a faulty sensor and my car will be back to me shortly
Appreciate 0
      02-02-2018, 12:34 AM   #567
CeeTeeX5
Major
760
Rep
1,100
Posts

Drives: 2018 X5 xDrive35i M-Sport
Join Date: Apr 2008
Location: Bellevue, WA

iTrader: (0)

Quote:
Originally Posted by DC F15 View Post
Was so weird driving to the dealership in limp mode. It was like it was stuck in eco pro. I'm sure they will call me tomorrow with some initial prognosis. Looking forward to hearing from my super hot service advisor. Seriously. She makes my visits much more pleasant. Got put in a base x5. The leather felt strange. I miss my m sport steering wheel. And I thought HK sound was standard on the x5. I was wrong and man do I miss it.
But all first world problems aside. I'm hoping it's just a faulty sensor and my car will be back to me shortly
fingers crossed for you that it's something simple. Definitely doesn't hurt to have a hot SA! They are all a bunch of old dudes at my dealership.
Appreciate 0
      02-02-2018, 01:47 AM   #568
Stev_chu
Private First Class
Stev_chu's Avatar
86
Rep
140
Posts

Drives: 2015 BMW X5
Join Date: Oct 2017
Location: NEW YORK

iTrader: (0)

Quote:
Originally Posted by DC F15 View Post
So less than a year into owning my 2017 X5.... I start the car today only to be greeted by our good friend the "check engine light" the drivetrain malfunction warning... drive moderately...
my last car.. (F30 335i with the same N55 engine) gave me three years of uninteerrupted fun.... this one.. not even a year.. and here we go.

snagged an appt for today at 515 local time with a loaner for me. Service guy said it should ok to make the 20 minute trip to the dealership.. if it feels liek it can't make it.. stop and call for a tow.

keeping fingers crossed. Good thing is.. might as well get the 1 year service done while its there...
Every time I comes here I see someone with a new problem with their car..so worried
Appreciate 0
      02-02-2018, 01:05 PM   #569
CeeTeeX5
Major
760
Rep
1,100
Posts

Drives: 2018 X5 xDrive35i M-Sport
Join Date: Apr 2008
Location: Bellevue, WA

iTrader: (0)

Quote:
Originally Posted by Stev_chu View Post
Every time I comes here I see someone with a new problem with their car..so worried
I wouldn't worry too much. Forums are where people go to post issues and in many cases, these issues are minor inconveniences/gripes/bugs. I'm nitpicky about things so I often end up discovering "problems" that a lot of people wouldn't even care about.
Appreciate 2
retx106.00

      02-02-2018, 04:01 PM   #570
marlin2911
Private First Class
marlin2911's Avatar
United_States
16
Rep
105
Posts

Drives: 2013 328i xDrive Sport Line
Join Date: Feb 2014
Location: Yardley, PA

iTrader: (0)

Garage List
Quote:
Originally Posted by Stev_chu View Post
Every time I comes here I see someone with a new problem with their car..so worried
I personally think the opposite - you should go take a look at the F30 forums, or even the E90 before that. Quite honestly the fact that the problems I see with the F15 compared to either of those 2 makes me extremely optimistic about the long term outlook for the X5. I am generally only seeing BMW getting better with issues, not worse.
Appreciate 1
      02-03-2018, 04:41 PM   #571
philude
New Member
15
Rep
21
Posts

Drives: M3
Join Date: Jun 2014
Location: Virginia

iTrader: (0)

My wife's 2017 X5 started up today without displaying the normal "Starting up navigation software...". I just boots right into the menu. Voice Control, navigation, and the map options all give me "Function not available". I've tried restarting iDrive by holding the mute/power button for 25 seconds, but even after the restart, it never loads the navigation software.

We're also running the lastest iDrive update so I can't restore/update to see if it resolves it. Not sure what happened to cause it honestly, it was working fine just yesterday
__________________
Instagram:
F80 - @hi_fve_m3
F15 - @hi_fve_x5
Appreciate 0
      02-03-2018, 10:37 PM   #572
DC F15
First Lieutenant
United_States
115
Rep
322
Posts

Drives: 2017 F15 35i Xdrive Space Grey
Join Date: Jul 2014
Location: Long Island ny

iTrader: (0)

Quote:
Originally Posted by CeeTeeX5 View Post
fingers crossed for you that it's something simple. Definitely doesn't hurt to have a hot SA! They are all a bunch of old dudes at my dealership.
Should I be worried that I havenít gotten a call back since Thursday. Left a message for the SA today and got nothing back.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 03:27 AM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST