BMW X5 and X6 Forum 2014-Current
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Post Reply
 
Thread Tools Search this Thread
      09-07-2019, 08:10 AM   #1
vastano
Captain
59
Rep
844
Posts

Drives: E90 M3
Join Date: Nov 2012
Location: Kansas City, MO

iTrader: (5)

Joyeauto Wireless Carplay thoughts/improvements

This thread is meant to be a wish list/troubleshooting list to send to Joyeauto for any improvements that we'd like to see made. The unit is 90% perfect, but heres a few changes i'd like to see to get closer to that 100%.

My personal requests:

1.) Being able to switch between 2 connected devices. When Carplay is active, it locks you out of the 'connected devices' menu

2.) On a phone running iOS 12 there is a black screen coming in and out of Carplay. This doesn't happen on my phone running iOS 13 beta so it may be fixed when the official iOS drops.

3.) This is a petty change, but it doesn't like it when you spin the iDrive controller fast.

4.) I'd like all the other iDrive button 'mappable.' For instance, i'd like to set my Nav button to open Waze.

Please keep this thread on topic, this isnt meant for install questions unless it is an improvement.
Appreciate 2
      09-07-2019, 09:04 PM   #2
DeeO
Captain
DeeO's Avatar
No_Country
292
Rep
728
Posts

Drives: Mein BMW F Fünfundachtzig
Join Date: Mar 2017
Location: I'm right here << lurking on the board!

iTrader: (8)

Interesting topic vastano. Hopefully someone with a F15/F85 factory installed CarPlay can chime in with what's possible and/or correctable. This way we have a more realistic expectation from this retrofit.

While this doesn't address all the questions you posted, I found this thread over on the G03 forum:https://x3.xbimmers.com/forums/showthread.php?t=1640460 Even the G05 forum have something to say about it: https://g05.bimmerpost.com/forums/sh....php?t=1545438

In the mean time, I'll browse a few more F/G forums to find more info...hth
__________________
Quote:
“Speed has never killed anyone. Suddenly becoming stationary, that's what gets you.”
― Jeremy Clarkson
Appreciate 1
      09-08-2019, 02:48 AM   #3
skoold2003
Second Lieutenant
52
Rep
224
Posts

Drives: 2010 M3, 2014 X5 50i M Sport
Join Date: Nov 2012
Location: Las Vegas

iTrader: (0)

Quote:
Originally Posted by vastano View Post
This thread is meant to be a wish list/troubleshooting list to send to Joyeauto for any improvements that we'd like to see made. The unit is 90% perfect, but heres a few changes i'd like to see to get closer to that 100%.

My personal requests:

1.) Being able to switch between 2 connected devices. When Carplay is active, it locks you out of the 'connected devices' menu

2.) On a phone running iOS 12 there is a black screen coming in and out of Carplay. This doesn't happen on my phone running iOS 13 beta so it may be fixed when the official iOS drops.

3.) This is a petty change, but it doesn't like it when you spin the iDrive controller fast.

4.) I'd like all the other iDrive button 'mappable.' For instance, i'd like to set my Nav button to open Waze.

Please keep this thread on topic, this isnt meant for install questions unless it is an improvement.
Hey it's good to see you started a thread for this. You should give a mention on the Wooohoooo thread so that all of the GB people can come over and share their thoughts. I just posted a reply over there telling a potential buyer the things that annoy me about the unit.. I'll put them here too.

1.) Being able to switch between 2 connected devices. When Carplay is active, it locks you out of the 'connected devices' menu
[COLOR="Red"]I don't have more than one device so I haven't noticed this one[/COLOR]

2.) On a phone running iOS 12 there is a black screen coming in and out of Carplay. This doesn't happen on my phone running iOS 13 beta so it may be fixed when the official iOS drops.
[COLOR="Red"]Are you referring to the black screen when switching between CarPlay and iDrive via long press of the back button? I have it too and it sucks.[/COLOR]

3.) This is a petty change, but it doesn't like it when you spin the iDrive controller fast.
[COLOR="Red"]I don't think this is petty.. I notice it too. It doesn't seem to happen when navigating via the steering wheel. [/COLOR]

4.) I'd like all the other iDrive button 'mappable.' For instance, i'd like to set my Nav button to open Waze.
[COLOR="Red"]This is by far my biggest gripe. It's a pain in the ass having to scroll between the music app and the nav app the hard way. If not settable they should at least have the buttons programmed to their respective functions.. like nav to nav, media to music and phone to phone. Is it better in IOS 13 since it looks like music and maps can be on the same screen?[/COLOR]

5.) When using the phone via CarPlay (external mic) the person on the other end of the line hears their echo. I suspect this is just feedback from the call coming from the speakers.

6.) Front camera never works in CarPlay.

Edit: adding 7

7.) A method to change songs without navigating to next song in music app. For example using the arrow keys by the numbers.
Appreciate 1
DeeO292.00

      09-08-2019, 09:51 AM   #4
DeeO
Captain
DeeO's Avatar
No_Country
292
Rep
728
Posts

Drives: Mein BMW F Fünfundachtzig
Join Date: Mar 2017
Location: I'm right here << lurking on the board!

iTrader: (8)

1.) One guy on the F30 forum said his contacts got co-mingled with his wife's contacts & learned to live with it, BUT this was on factory OEM BMW CarPlay. Both my wife & I have our phones paired to iDrive/CarPlay, but not simultaneously. Not sure I want/need this feature.

2). I don't experience this (less than 1 sec. switching). In the Joyeauto UI, make sure that rear and front cameras, DVD, BT, TV, and DVR are ALL turned off in the settings menu.

3.) Thumb wheel on steering wheel works fine, yes iDrive wheel is indeed laggy.

4.) Programming memory buttons 1-8? I'll try experimenting with this & report back. Or just say: 'Hey Siri'!

5.) Experienced this early on, but no longer have this echo problem. Feedback from the placement of the mic, perhaps?

6.) See number 2.
__________________
Quote:
“Speed has never killed anyone. Suddenly becoming stationary, that's what gets you.”
― Jeremy Clarkson
Appreciate 1
      09-08-2019, 12:01 PM   #5
skoold2003
Second Lieutenant
52
Rep
224
Posts

Drives: 2010 M3, 2014 X5 50i M Sport
Join Date: Nov 2012
Location: Las Vegas

iTrader: (0)

Quote:
Originally Posted by DeeO View Post
1.) One guy on the F30 forum said his contacts got co-mingled with his wife's contacts & learned to live with it, BUT this was on factory OEM BMW CarPlay. Both my wife & I have our phones paired to iDrive/CarPlay, but not simultaneously. Not sure I want/need this feature.

2). I don't experience this (less than 1 sec. switching). In the Joyeauto UI, make sure that rear and front cameras, DVD, BT, TV, and DVR are ALL turned off in the settings menu.

3.) Thumb wheel on steering wheel works fine, yes iDrive wheel is indeed laggy.

4.) Programming memory buttons 1-8? I'll try experimenting with this & report back. Or just say: 'Hey Siri'!

5.) Experienced this early on, but no longer have this echo problem. Feedback from the placement of the mic, perhaps?

6.) See number 2.
It looks like you were right about number 2. In my settings there was nothing selected under TV. I set it to off and I'm not seeing that intermediate black screen anymore. Good call amigo!

It's still a workaround though.. I'd rather see the cam come up when you pull up to an object.
Appreciate 1
DeeO292.00

      09-08-2019, 12:59 PM   #6
DeeO
Captain
DeeO's Avatar
No_Country
292
Rep
728
Posts

Drives: Mein BMW F Fünfundachtzig
Join Date: Mar 2017
Location: I'm right here << lurking on the board!

iTrader: (8)

Quote:
Originally Posted by skoold2003 View Post
It looks like you were right about number 2. In my settings there was nothing selected under TV. I set it to off and I'm not seeing that intermediate black screen anymore. Good call amigo!

It's still a workaround though.. I'd rather see the cam come up when you pull up to an object.
Let's start a petition and forward it to the company with our demands! Or else...
__________________
Quote:
“Speed has never killed anyone. Suddenly becoming stationary, that's what gets you.”
― Jeremy Clarkson
Appreciate 0
      09-08-2019, 01:02 PM   #7
skoold2003
Second Lieutenant
52
Rep
224
Posts

Drives: 2010 M3, 2014 X5 50i M Sport
Join Date: Nov 2012
Location: Las Vegas

iTrader: (0)

Quote:
Originally Posted by DeeO View Post
Quote:
Originally Posted by skoold2003 View Post
It looks like you were right about number 2. In my settings there was nothing selected under TV. I set it to off and I'm not seeing that intermediate black screen anymore. Good call amigo!

It's still a workaround though.. I'd rather see the cam come up when you pull up to an object.
Let's start a petition and forward it to the company with our demands! Or else...
Well we could probably line up a bunch more customers for them.. If they can work out the bugs and make use happy. That would be the best leverage to motivate them.
Appreciate 0
      09-08-2019, 07:38 PM   #8
-c-
Colonel
-c-'s Avatar
United_States
454
Rep
2,313
Posts

Drives: bnw
Join Date: May 2010
Location: Chicago

iTrader: (5)

Another thing that would be great is if they let you register somehow and get update emails sent to you when updates are available for their unit..
Appreciate 0
      09-08-2019, 07:50 PM   #9
skoold2003
Second Lieutenant
52
Rep
224
Posts

Drives: 2010 M3, 2014 X5 50i M Sport
Join Date: Nov 2012
Location: Las Vegas

iTrader: (0)

Quote:
Originally Posted by -c- View Post
Another thing that would be great is if they let you register somehow and get update emails sent to you when updates are available for their unit..
Yea or maybe just point them to this thread? I wonder if they can even access bimmerpost or if they're blocked by the great firewall?
Appreciate 0
      09-12-2019, 03:39 PM   #10
golovan
Private First Class
United_States
18
Rep
194
Posts

Drives: 2015 X5 35D
Join Date: Jul 2012
Location: Houston

iTrader: (0)

Did anyone experience any problems with stock cameras when switching gear to reverse? I get a black screen with park sensor lines.
Appreciate 0
      09-12-2019, 03:54 PM   #11
DeeO
Captain
DeeO's Avatar
No_Country
292
Rep
728
Posts

Drives: Mein BMW F Fünfundachtzig
Join Date: Mar 2017
Location: I'm right here << lurking on the board!

iTrader: (8)

Quote:
Originally Posted by golovan View Post
Did anyone experience any problems with stock cameras when switching gear to reverse? I get a black screen with park sensor lines.
No, but if you have factory cameras, go into Joyeauto menu (BMW logo) and turn off all cameras, DVD, etc
__________________
Quote:
“Speed has never killed anyone. Suddenly becoming stationary, that's what gets you.”
― Jeremy Clarkson
Appreciate 0
      09-12-2019, 04:51 PM   #12
golovan
Private First Class
United_States
18
Rep
194
Posts

Drives: 2015 X5 35D
Join Date: Jul 2012
Location: Houston

iTrader: (0)

Quote:
Originally Posted by DeeO View Post
No, but if you have factory cameras, go into Joyeauto menu (BMW logo) and turn off all cameras, DVD, etc
I thought I did it, but I will go and check it again. I think the problem is somewhere either in settings or in firmware of the unit, because it does show backup and surround cameras when I am in parking and press park button.
Appreciate 0
      09-12-2019, 08:59 PM   #13
skoold2003
Second Lieutenant
52
Rep
224
Posts

Drives: 2010 M3, 2014 X5 50i M Sport
Join Date: Nov 2012
Location: Las Vegas

iTrader: (0)

Quote:
Originally Posted by golovan View Post
Quote:
Originally Posted by DeeO View Post
No, but if you have factory cameras, go into Joyeauto menu (BMW logo) and turn off all cameras, DVD, etc
I thought I did it, but I will go and check it again. I think the problem is somewhere either in settings or in firmware of the unit, because it does show backup and surround cameras when I am in parking and press park button.
I've had a couple of cases where it was black screen in reverse.. But those were just one off things
Appreciate 0
      09-13-2019, 08:25 AM   #14
golovan
Private First Class
United_States
18
Rep
194
Posts

Drives: 2015 X5 35D
Join Date: Jul 2012
Location: Houston

iTrader: (0)

I texted to Joyeauto and got their response. It was: "Dip switch 8 set ON". I didn't fully understand what they meant, but I will check it again today or tomorrow.
Appreciate 0
      09-13-2019, 08:34 AM   #15
vastano
Captain
59
Rep
844
Posts

Drives: E90 M3
Join Date: Nov 2012
Location: Kansas City, MO

iTrader: (5)

Quote:
Originally Posted by golovan View Post
I texted to Joyeauto and got their response. It was: "Dip switch 8 set ON". I didn't fully understand what they meant, but I will check it again today or tomorrow.
There are 8 dipswitches on the bottom of the carplay unit. Only #8 should be on, all others off.
Appreciate 0
      09-15-2019, 03:57 PM   #16
Maverik259
Brigadier General
Maverik259's Avatar
United_States
1986
Rep
3,686
Posts

Drives: F15 50i
Join Date: Jun 2017
Location: Virginia

iTrader: (0)

Garage List
2014 X5 50i  [0.00]
Y'all shoulda gotten the android units.
__________________
'07 Yamaha R1 (sold)
'06 C55 AMG (sold)
'14 X5 50i, RC Ultimate, MP black kidney grills, MP pedals, MP kick plates, F85 Nappa knee bolsters, IND Black Roundels, M Side Mirrors, MP Alcantara wheel
Appreciate 1
DeeO292.00

      09-15-2019, 04:16 PM   #17
DeeO
Captain
DeeO's Avatar
No_Country
292
Rep
728
Posts

Drives: Mein BMW F Fünfundachtzig
Join Date: Mar 2017
Location: I'm right here << lurking on the board!

iTrader: (8)

Quote:
Originally Posted by Maverik259 View Post
Y'all shoulda gotten the android units.
And switch to Android? Haha. Nice try Mav
__________________
Quote:
“Speed has never killed anyone. Suddenly becoming stationary, that's what gets you.”
― Jeremy Clarkson
Appreciate 0
      09-15-2019, 08:09 PM   #18
skoold2003
Second Lieutenant
52
Rep
224
Posts

Drives: 2010 M3, 2014 X5 50i M Sport
Join Date: Nov 2012
Location: Las Vegas

iTrader: (0)

Quote:
Originally Posted by Maverik259 View Post
Y'all shoulda gotten the android units.
You're probably right. Unfortunately there wasn't enough people who could give real feedback on these units before. We were basically guinea pigs.
Appreciate 0
      09-16-2019, 02:49 PM   #19
vastano
Captain
59
Rep
844
Posts

Drives: E90 M3
Join Date: Nov 2012
Location: Kansas City, MO

iTrader: (5)

I realize im the OP, but has anyone contacted Joyeauto referencing this thread? If not I was going to go ahead and send them the info via WhatsApp. Of course if someone has a contact already, feel free to go ahead and send them the link.
Appreciate 0
      09-16-2019, 03:30 PM   #20
skoold2003
Second Lieutenant
52
Rep
224
Posts

Drives: 2010 M3, 2014 X5 50i M Sport
Join Date: Nov 2012
Location: Las Vegas

iTrader: (0)

Quote:
Originally Posted by vastano View Post
I realize im the OP, but has anyone contacted Joyeauto referencing this thread? If not I was going to go ahead and send them the info via WhatsApp. Of course if someone has a contact already, feel free to go ahead and send them the link.
No I think that you're the head guy on this one. Probably just start by asking if they can or will work on fixing bugs and implementing improvements. If they can do it ask if they can join the forum.
Also, I think we should prioritize things that we want fixed. For me the highest priority items are 4 - 7(just added) - 6 - 5
Appreciate 0
      09-19-2019, 02:06 PM   #21
vastano
Captain
59
Rep
844
Posts

Drives: E90 M3
Join Date: Nov 2012
Location: Kansas City, MO

iTrader: (5)

I sent Joyeauto a link to this thread and they said they appreciate it and will take a look at it.
Appreciate 1
      09-19-2019, 05:57 PM   #22
-c-
Colonel
-c-'s Avatar
United_States
454
Rep
2,313
Posts

Drives: bnw
Join Date: May 2010
Location: Chicago

iTrader: (5)

Tapping into the factory mic would be nice.

Also designing the unit to be fitted into the tight space would be a plus

Most of the complaints seem to be trying to fit it into the cramped space
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:12 AM.




xbimmers
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST