BMW X5 and X6 Forum 2014-Current
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Post Reply
 
Thread Tools Search this Thread
      08-04-2019, 09:54 PM   #749
lshiroda1
New Member
2
Rep
20
Posts

Drives: 2017 F15 X5,
Join Date: Dec 2017
Location: Louisiana

iTrader: (0)

Garage List
2017 BMW X5  [0.00]
Anyone know the cost of replacing the battery in a 2017 F15 X5 xDrive35i at a dealer? I know dealer costs can vary, but does anyone have a roundabout figure?
Appreciate 0
      08-04-2019, 11:58 PM   #750
mrfochon
First Lieutenant
United_States
95
Rep
355
Posts

Drives: X5 F15 M package
Join Date: Aug 2018
Location: NY

iTrader: (0)

Garage List
Quote:
Originally Posted by lshiroda1 View Post
Anyone know the cost of replacing the battery in a 2017 F15 X5 xDrive35i
The price of a battery
Appreciate 0
      08-08-2019, 04:53 PM   #751
ManImCool
Private
8
Rep
91
Posts

Drives: F15 X5
Join Date: Mar 2016
Location: Houston

iTrader: (1)

Quote:
Originally Posted by ManImCool View Post
Anyone have any ideas why my coasting feature stopped working? Nothing has changed; haven't coded anything in a long time. It's still checked in the menu options, attempting to use without cruise control, in eco pro, shifter to the right, etc. I used to use coasting all the time but now it won't work at all.

Per another thread, I tried resetting my tire sensors numerous times to no avail!
Quote:
Originally Posted by InsipidMonkey View Post
Low battery charge? Try charging your battery fully and see if it works.
Quote:
Originally Posted by ManImCool View Post
Hmm - you actually might be on to something - I installed a 12" subwoofer a few weeks ago which obviously draws more power than the car is used to, and I *think* the car stopped coasting in the same week or possibly the following week after the sub install.

Don't get any low voltage warnings or anything but definitely worth a shot!
Update: Bought a CTEK trickle charger, and the battery indeed was on the low end (I think only 2 lights out of 7/8 total lit up). Overnight and in the morning, I was fully charged and ready to go, so I took it for a ride, but sadly, coasting still doesn't work!!!
Appreciate 0
      08-08-2019, 05:51 PM   #752
CatalinP
Captain
366
Rep
721
Posts

Drives: BMW X5 F15 2014 3.0xd
Join Date: Aug 2017
Location: RO

iTrader: (0)

Those 2 lights are not indicating the charge level... They show the charging sequence... You better read the manual of the charger...
Appreciate 0
      08-09-2019, 04:06 AM   #753
ger0nim0
Registered
0
Rep
1
Posts

Drives: bmw x5 2018 f15 4.0 xd
Join Date: Aug 2019
Location: romania

iTrader: (0)

SOS Call System Failure

I've got this issue for a few weeks already.
I checked on the forums and it suggested that i might try to change the backup battery, but it was impossible for me to find it...
Can anyone help me to locate it?

Or maybe the MOST fiber optic ring connector which seems to be the reason of the fault in other cases...?

In my case everything it's working fine except the SOS call system...

Thank you!
Appreciate 0
      08-14-2019, 10:48 AM   #754
ManImCool
Private
8
Rep
91
Posts

Drives: F15 X5
Join Date: Mar 2016
Location: Houston

iTrader: (1)

Quote:
Originally Posted by CatalinP View Post
Those 2 lights are not indicating the charge level... They show the charging sequence... You better read the manual of the charger...
So I read the manual, retried charging with the CTEK in auto+recond mode; it got to the 3rd light within seconds, and took overnight to fill 7 lights, with the 7th green and the rest yellow.

Took it for a drive, still no coasting. Sigh.
Appreciate 0
      08-14-2019, 08:59 PM   #755
lshiroda1
New Member
2
Rep
20
Posts

Drives: 2017 F15 X5,
Join Date: Dec 2017
Location: Louisiana

iTrader: (0)

Garage List
2017 BMW X5  [0.00]
Looks like I'm going to need to replace the pads and rotors on my '17 F15 xdrive35i. Any idea at what it'll cost me at a dealer? Non Msport btw
Appreciate 0
      08-16-2019, 01:07 PM   #756
A-4WD
Long Time Bimmer Fan
Canada
199
Rep
146
Posts

Drives: 2014 X5 35i
Join Date: Nov 2017
Location: Toronto

iTrader: (0)

Quote:
Originally Posted by lshiroda1 View Post
Looks like I'm going to need to replace the pads and rotors on my '17 F15 xdrive35i. Any idea at what it'll cost me at a dealer? Non Msport btw
$1500+ CAD (I know you're in the US) and don't settle for cheaper pads. All you'll get is tonnes of brake dust. OEM ones are virtually dust-free...I had a BMW specialist try it for me but I ended up with OEMs in the end.
__________________
2014 X5 XDrive 35i - Current
2010 X5 XDrive 4.8iS - Traded
1990 325iS - Sold
1985 318i - RIP
Appreciate 0
      08-26-2019, 09:54 AM   #757
Bmwit
Registered
0
Rep
1
Posts

Drives: BMW X5 F15
Join Date: Aug 2019
Location: United kingdom

iTrader: (0)

Lines on Navigation screen

Has anyone ever seen this problem with the navigation screen? Any ideas on how to fix it? Thanks in advance.
Attached Images
 
Appreciate 0
      08-26-2019, 02:16 PM   #758
mudbug
Registered
0
Rep
4
Posts

Drives: Black
Join Date: Sep 2009
Location: norway

iTrader: (0)

Hi, My car is out of guaranti in May next year. I heard some dunking noise in background when car is in ide. Is it normale engine nosie? Thanks
Appreciate 0
      08-30-2019, 03:27 PM   #759
Roman_H
Registered
United_States
0
Rep
1
Posts

Drives: BMW X5 50i (F15)M-Package
Join Date: Aug 2019
Location: New York

iTrader: (0)

CEL+Engine Drivetrain Malfunction

51K Miles

CEL+Engine Drivetrain Malfunction resulting in rough idling and a significant loss of power. Codes: P00BC/$07E8+P0172. Also throwing codes: P0300+P0304+P0303+P0302 (Cylinder 1-4 Misfire. Any ideas/suggestions?

Note: I cleared the codes and the vehicles drives perfectly well for 3-4 miles then the engine light and drive train malfunction warning comes back and along with it the rough idle and loss of power
Appreciate 0
      09-02-2019, 06:28 PM   #760
RED_Y_
Lieutenant
United_States
230
Rep
495
Posts

Drives: 2014 X5 3.5d
Join Date: Sep 2017
Location: SF Bay Area

iTrader: (0)

Quote:
Originally Posted by Roman_H View Post
51K Miles

CEL+Engine Drivetrain Malfunction resulting in rough idling and a significant loss of power. Codes: P00BC/$07E8+P0172. Also throwing codes: P0300+P0304+P0303+P0302 (Cylinder 1-4 Misfire. Any ideas/suggestions?

Note: I cleared the codes and the vehicles drives perfectly well for 3-4 miles then the engine light and drive train malfunction warning comes back and along with it the rough idle and loss of power
P00BC/$07E8 Circuit Range/Performance Flow Too Low and P0172 is System Too Rich point out to the MAF problem.I would guess this the the root cause which is causing the misfires. Replace MAF.
Appreciate 0
      09-04-2019, 07:54 AM   #761
mpowered5
Private First Class
mpowered5's Avatar
320
Rep
152
Posts

Drives: E34 M5
Join Date: Dec 2017
Location: North of Toronto

iTrader: (0)

Anyone have their pinion seal go?
Front of the rear diff where the driveshaft meets?
Attached Images
 
__________________
2015 X5 35d M sport
2005 330xi M Tech 1
1991 M5
1988 M5
Appreciate 0
      09-08-2019, 12:20 PM   #762
captain-slap-a-ho
New Member
0
Rep
8
Posts

Drives: X5 30D
Join Date: Sep 2019
Location: London

iTrader: (0)

Smile F15 Sat Nav update not working or asking for FSC code? Please help!

Hi All, yes another Sat Nav question . I currently have an F15 X5 and want to update to the latest Sat Nav version for Europe. I've downloaded Road Map Europe Next 2019-1 and have unpacked it using winrar. Currently I'm running 2014 NEXT.

When I plug my USB (from the centre console - no usb point in glove box - 64GB USB) it asks if I want to update which I click yes then nothing seems to happen. It doesn't ask for an FSC code (which I have) and I can't see an update status bar or anything? I've left it for over an hour whilst driving and still not updated.

Any ideas would be much appreciated and I've attached some pics

Many thanks
Attached Images
   
Appreciate 0
      09-09-2019, 08:12 AM   #763
Bottled
Registered
Czech_Republic
0
Rep
2
Posts

Drives: F15
Join Date: Dec 2018
Location: Czech rep

iTrader: (0)

Quote:
Originally Posted by mpowered5 View Post
Anyone have their pinion seal go?
Front of the rear diff where the driveshaft meets?
Having the same issue after 120K km.
Just gave it to indy shop to replace all 3 shaft seals.
Name:  69EF35A8-3951-4097-A606-19F9FD458685.jpg
Views: 486
Size:  289.4 KB
First problem so far.

What is your mileage as its kinda rusty per the picture

Last edited by Bottled; 09-09-2019 at 08:24 AM..
Appreciate 0
      09-09-2019, 08:49 AM   #764
ComasF15
Private First Class
33
Rep
116
Posts

Drives: Silver
Join Date: Jan 2019
Location: Emerald Coast

iTrader: (0)

Quote:
Originally Posted by lshiroda1 View Post
Anyone know the cost of replacing the battery in a 2017 F15 X5 xDrive35i at a dealer? I know dealer costs can vary, but does anyone have a roundabout figure?
~$500

FWIW Batteries Plus does it for~$300 and they can register the new battery. I had this done on my 2015.
Appreciate 0
      09-10-2019, 11:14 PM   #765
GasGiant
New Member
0
Rep
13
Posts

Drives: F15 X35i 2014
Join Date: Apr 2018
Location: Philadelphia

iTrader: (0)

Yes, on a 2014 with exactly 80,000 miles. Fix it ASAP before you need to replace the rear differential! My indy guy charged me USD $500.
Appreciate 0
      09-11-2019, 04:04 AM   #766
mpowered5
Private First Class
mpowered5's Avatar
320
Rep
152
Posts

Drives: E34 M5
Join Date: Dec 2017
Location: North of Toronto

iTrader: (0)

Quote:
Originally Posted by Bottled View Post
Quote:
Originally Posted by mpowered5 View Post
Anyone have their pinion seal go?
Front of the rear diff where the driveshaft meets?
Having the same issue after 120K km.
Just gave it to indy shop to replace all 3 shaft seals.
Attachment 2138189
First problem so far.

What is your mileage as its kinda rusty per the picture
Has only 65,000km on it. Canadian winters take their toll
__________________
2015 X5 35d M sport
2005 330xi M Tech 1
1991 M5
1988 M5
Appreciate 0
      09-15-2019, 07:47 PM   #767
Kanuc
Private First Class
Canada
10
Rep
165
Posts

Drives: 2013 X6M Melbourne Red
Join Date: Nov 2009
Location: Calgary

iTrader: (0)

Brake shuddering

Hi. 2016 X5 35d, 70000km, new tires.

When I go down a long steep hill, car pretty full of ppl and cargo, gradually I start to get shuddering in the car. Not through brake pedal, instead whole car just shakes. This occurred on a hot day. This did not recur on a similar incline on a cool day during rain.

Dealer checked out brake condition visually. pads look close to new, rotors look good. However, service computer shows front and rear brake job due in <5000km.

Dealer checked wheel alignment, looks good.

Dealer came up empty.

If this is not uncommon, there must be a service bulletin, but dealer said none exists.
Appreciate 0
      09-17-2019, 05:47 AM   #768
travellingkiwi
New Member
5
Rep
21
Posts

Drives: f15 e87 fireblade
Join Date: Sep 2019
Location: London

iTrader: (0)

Quote:
Originally Posted by Kanuc View Post
Hi. 2016 X5 35d, 70000km, new tires.

When I go down a long steep hill, car pretty full of ppl and cargo, gradually I start to get shuddering in the car. Not through brake pedal, instead whole car just shakes. This occurred on a hot day. This did not recur on a similar incline on a cool day during rain.
Shuddering while using the brakes? Or shuddering when engine braking?

Last edited by travellingkiwi; 09-17-2019 at 05:48 AM.. Reason: I can't type
Appreciate 0
      09-26-2019, 10:08 AM   #769
Billy416
Registered
0
Rep
1
Posts

Drives: 2014 BMW X5 5.0i
Join Date: Sep 2019
Location: Toronto

iTrader: (0)

Hello everyone,

First time posting here but I have an issue that I can't figure out.
Car 2014 X5 5.0i with 140KM/ 86K miles

When I drive the car I hear a very high pitch sound coming from the engine, and sometimes when I park it a dn run in the store I hear it as well.
Appreciate 0
      09-28-2019, 11:15 AM   #770
luftika7
Registered
0
Rep
1
Posts

Drives: bmw X5
Join Date: Sep 2019
Location: CT

iTrader: (0)

will these wheels fit my 2015 X5

I am not sure if they are OEM X5 wheels or from something else and will they fit on 2015 X5
Attached Images
   
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:59 AM.




xbimmers
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST