BMW X5 and X6 Forum 2014-Current
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Post Reply
 
Thread Tools Search this Thread
      07-13-2021, 08:12 PM   #1
ZPM
New Member
United_States
1
Rep
11
Posts

Drives: 2015 BMW X5 sDrive35i
Join Date: Aug 2019
Location: Austin, Texas, USA

iTrader: (0)

2015 F15 rear camera failure

I disconnected my battery for several hours to work on my radiator fan. Upon my next drive I noticed the rear camera was not working. The screen looks like this:



I have ISTA and ICOM. The diagnostic is saying:

S0313 No communication possible with: All-round vision camera.
D414B4 No message (status, qualifier rear-view, 0x37A), receiver PMA, transmitter TRSVC.
E09402 Message (data, display, drive train, 0x3FD) not current, receiver GWS (PT-CAN).

Also, in the system tree diagram, I'm showing "no communication" with the Body Domain Controller.

Is all this caused by my disconnecting the battery? Is some sort of re-learn required?

(You'll also see that my right adaptive headlight is no longer working. I'm hoping to use ESYS+ICOM to simply code out adaptive headlights. Appreciate any insights on what system to target, and the correct code value to use.)
Attached Images
  
Appreciate 0
      03-07-2022, 05:06 AM   #2
GediminasB
Registered
0
Rep
1
Posts

Drives: BMW F10
Join Date: Mar 2022
Location: Lithuania

iTrader: (0)

In our workshop was F15 with wrong version headlights and rear view camera was not working.
Have changed headlights and TMS to correct ones and it works now.
Problem in TMS.

Last edited by GediminasB; 03-07-2022 at 08:17 AM..
Appreciate 0
      03-07-2022, 12:30 PM   #3
ZPM
New Member
United_States
1
Rep
11
Posts

Drives: 2015 BMW X5 sDrive35i
Join Date: Aug 2019
Location: Austin, Texas, USA

iTrader: (0)

Thank you! In my case, my headlights are original and the camera was working. Suddenly stopped working. Appreciate your suggestion!

I've determined that my body domain controller is faulty. I've always had a problem with the adaptive headlight system going offline randomly. It's gotten worse over the years and is now full-time faulting. Since the rear camera derives it's parking assistance guide lines (red and green lines drawn on the display screen to guide you) I suspect the BDC failure is now affecting this part of the rear view camera operation. I'll replace the BDC and see.

Last edited by ZPM; 03-07-2022 at 12:49 PM..
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:52 AM.




xbimmers
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST